<!DOCTYPE html> <html lang="en-US" xmlns:og="http://opengraphprotocol.org/schema/" xmlns:fb="http://www.facebook.com/2008/fbml"> <head><link rel="dns-prefetch" href="//ajax.googleapis.com">
<link rel="dns-prefetch" href="//connect.facebook.net">
<link rel="dns-prefetch" href="//www.google.com">
<link rel="dns-prefetch" href="//fonts.googleapis.com">
<link rel="preload" href="https://www.dresdenenterprise.com/wp-content/cache/borlabs_cache/1/js/4b178083852ef90045bc4bb2cfbbc01acade7fc9_https.js" as="script">
<link rel="preload" href="https://www.dresdenenterprise.com/wp-content/cache/borlabs_cache/1/css/79a7dbbd65edefa7d8d86f2e4bb8f7c0be3b599f_https.css" as="style">
<link rel="stylesheet" href="https://www.dresdenenterprise.com/wp-content/cache/borlabs_cache/1/css/79a7dbbd65edefa7d8d86f2e4bb8f7c0be3b599f_https.css" type="text/css" media="all"><link href="https://fonts.googleapis.com/css?family=Oswald%3A400" rel="stylesheet"> <meta charset="UTF-8" /> <meta name="viewport" content="width=device-width, initial-scale=1.0" /> <meta http-equiv="X-UA-Compatible" content="IE=edge" /> <link rel="profile" href="http://gmpg.org/xfn/11" /> <link rel="pingback" href="https://www.dresdenenterprise.com/xmlrpc.php" />   <!--[if lt IE 9]> <script src="https://www.dresdenenterprise.com/wp-content/themes/bb-theme/js/html5shiv.js"></script> <script src="https://www.dresdenenterprise.com/wp-content/themes/bb-theme/js/respond.min.js"></script> <![endif]--> <title>Not a Typical Tuesday &#8211; Dresden Enterprise</title>  <link rel='dns-prefetch' href='//ajax.googleapis.com' /> <link rel='dns-prefetch' href='//www.google.com' /> <link rel='dns-prefetch' href='//fonts.googleapis.com' /> <link href='https://fonts.gstatic.com' crossorigin rel='preconnect' /> <link rel="alternate" type="application/rss+xml" title="Dresden Enterprise &raquo; Feed" href="https://www.dresdenenterprise.com/feed/" /> <link rel="alternate" type="application/rss+xml" title="Dresden Enterprise &raquo; Comments Feed" href="https://www.dresdenenterprise.com/comments/feed/" /> <link rel="alternate" type="application/rss+xml" title="Dresden Enterprise &raquo; Not a Typical Tuesday Comments Feed" href="https://www.dresdenenterprise.com/2022/09/16/not-a-typical-tuesday/feed/" /> <meta property="og:title" content="Not a Typical Tuesday"/><meta property="og:type" content="article"/><meta property="og:url" content="https://www.dresdenenterprise.com/2022/09/16/not-a-typical-tuesday/"/><meta property="og:site_name" content="Dresden Enterprise"/><meta property="og:image" content="https://www.dresdenenterprise.com/wp-content/uploads/2022/09/Rons-Ravings-WEB-1.jpg"/>                       <style id='wp-polls-inline-css'>
.wp-polls .pollbar {
	margin: 1px;
	font-size: 6px;
	line-height: 8px;
	height: 8px;
	background-image: url('https://www.dresdenenterprise.com/wp-content/plugins/webads-polls/images/default/pollbg.gif');
	border: 1px solid #c8c8c8;
}

</style>                                                        <link rel="https://api.w.org/" href="https://www.dresdenenterprise.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.dresdenenterprise.com/wp-json/wp/v2/posts/252101" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.dresdenenterprise.com/xmlrpc.php?rsd" /> <link rel='prev' title='Dresden Seeking Funding for Tornado-Related Projects' href='https://www.dresdenenterprise.com/2022/09/16/dresden-seeking-funding-for-tornado-related-projects/' /> <link rel='next' title='UTM Invites High School Students to Fall Preview Days' href='https://www.dresdenenterprise.com/2022/09/16/utm-invites-high-school-students-to-fall-preview-days/' /> <link rel="canonical" href="https://www.dresdenenterprise.com/2022/09/16/not-a-typical-tuesday/" /> <link rel='shortlink' href='https://www.dresdenenterprise.com/?p=252101' /> <link rel="alternate" type="application/json+oembed" href="https://www.dresdenenterprise.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.dresdenenterprise.com%2F2022%2F09%2F16%2Fnot-a-typical-tuesday%2F" /> <link rel="alternate" type="text/xml+oembed" href="https://www.dresdenenterprise.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.dresdenenterprise.com%2F2022%2F09%2F16%2Fnot-a-typical-tuesday%2F&#038;format=xml" />  <style type="text/css" media="screen">
	.g { margin:0px; padding:0px; overflow:hidden; line-height:1; zoom:1; }
	.g img { height:auto; }
	.g-col { position:relative; float:left; }
	.g-col:first-child { margin-left: 0; }
	.g-col:last-child { margin-right: 0; }
	.g-1 { margin:0px 0px 0px 0px;width:100%; max-width:300px; height:100%; max-height:250px; }
	@media only screen and (max-width: 480px) {
		.g-col, .g-dyn, .g-single { width:100%; margin-left:0; margin-right:0; }
	}
</style>  <link rel="shortcut icon" href="https://www.dresdenenterprise.com/wp-content/uploads/2021/03/favicon-16x16-1.png"/> <script src='https://ajax.googleapis.com/ajax/libs/jquery/1.12.4/jquery.min.js?ver=1.12.4' id='jquery-js'></script><script async defer crossorigin="anonymous" src="https://connect.facebook.net/en_US/sdk.js#xfbml=1&version=v5.0"></script><script src='https://www.google.com/recaptcha/api.js?ver=5.5.10' id='recaptcha-scripts-js'></script><script type="text/javascript" src="https://www.dresdenenterprise.com/wp-content/cache/borlabs_cache/1/js/4b178083852ef90045bc4bb2cfbbc01acade7fc9_https.js"></script></head> <body class="post-template-default single single-post postid-252101 single-format-standard ecwd-theme-parent-bb-theme ecwd-theme-child-bb-theme-child fl-framework-bootstrap fl-preset-color01 fl-fixed-width fl-has-sidebar" itemscope="itemscope" itemtype="http://schema.org/WebPage"> <a aria-label="Skip to content" class="fl-screen-reader-text" href="#fl-main-content">Skip to content</a><div> <div class="fl-page-bar"> <div class="fl-page-bar-container container"> <div class="fl-page-bar-row row"> <div class="col-md-8 hidden-sm text-left clearfix"> <div class="breakingNews" id="bn7"> <div class="bn-title"><h2></h2><span></span></div> <ul> <li><a href="https://www.dresdenenterprise.com/2022/09/16/lions-deliver-big-63-0-homecoming-win-over-pioneers/">Lions Deliver Big 63-0 Homecoming Win Over Pioneers</a></li> <li><a href="https://www.dresdenenterprise.com/2022/09/16/running-for-gold/">Running for Gold</a></li> <li><a href="https://www.dresdenenterprise.com/2022/09/16/gleason-jr-high-homecoming-and/">Gleason Jr. High Homecoming</a></li> <li><a href="https://www.dresdenenterprise.com/2022/09/16/homecoming-queen-crowned-court-presented-at-dhs/">Homecoming Queen Crowned, Court Presented at DHS</a></li> <li><a href="https://www.dresdenenterprise.com/2022/09/16/state-county-officials-encouraging-voter-registration/">State, county officials encouraging voter registration</a></li> <li><a href="https://www.dresdenenterprise.com/2022/09/16/tn-soybean-festival-2022-highlights/">TN Soybean Festival 2022 Highlights</a></li> <li><a href="https://www.dresdenenterprise.com/2022/09/16/a-special-thanks/">A Special Thanks</a></li> <li><a href="https://www.dresdenenterprise.com/2022/09/09/tater-town-2022/">Tater Town 2022</a></li> <li><a href="https://www.dresdenenterprise.com/2022/09/09/vj-day-remembered/">VJ Day Remembered</a></li> <li><a href="https://www.dresdenenterprise.com/2022/09/09/sheriff-mike-wilson-retires-after-46-years/">Sheriff Mike Wilson Retires After 46 Years</a></li> </ul> <div class="bn-navi"> <span></span> <span></span> </div> </div>  <div class="fl-page-bar-text fl-page-bar-text-1"></div></div> <div class="col-md-4 col-sm-12 text-right clearfix"><ul id="menu-top-bar-menu" class="fl-page-bar-nav nav navbar-nav menu"><li id="menu-item-284" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-284 nav-item"><a href="https://www.dresdenenterprise.com/contact-us/" class="nav-link">Contact Us</a></li> <li id="menu-item-285" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-285 nav-item"><a target="_blank" rel="noopener noreferrer" href="http://1686.newstogo.us/editionviewer/default.aspx?Publication=ba990205-ee81-4972-941c-a544fa341ca1" class="nav-link">E-Edition</a></li> <li id="menu-item-286" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-286 nav-item"><a target="_blank" rel="noopener noreferrer" href="http://1686.newstogo.us/editionviewer/default.aspx?Publication=ba990205-ee81-4972-941c-a544fa341ca1&#038;view=subscribe" class="nav-link">Subscribe</a></li> <li id="menu-item-287" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-287 nav-item"><a target="_blank" rel="noopener noreferrer" href="http://1686.newstogo.us/editionviewer/default.aspx?Publication=ba990205-ee81-4972-941c-a544fa341ca1&#038;view=archives" class="nav-link">Archives</a></li> </ul> <div class="fl-social-icons"> <a href="https://www.facebook.com/DresdenEnterprise/" target="_blank" rel="noopener noreferrer"><span class="sr-only">Facebook</span><i aria-hidden="true" class="fab fa-facebook-f mono"></i></a><a href="mailto:enterprise@dresdenenterprise.com" rel="noopener noreferrer"><span class="sr-only">Email</span><i aria-hidden="true" class="fas fa-envelope mono"></i></a></div> </div> </div> </div> </div> </div> <div class="fl-page"> <header class="fl-page-header fl-page-header-primary fl-page-nav-bottom fl-page-nav-toggle-button fl-page-nav-toggle-visible-mobile" itemscope="itemscope" itemtype="http://schema.org/WPHeader"> <div class="fl-page-header-wrap"> <div class="fl-page-header-container container"> <div class="fl-page-header-row row"> <div class="col-md-8 col-sm-8"> <div class="fl-page-header-logo" itemscope="itemscope" itemtype="http://schema.org/Organization"> <a href="https://www.dresdenenterprise.com" itemprop="url"><img loading="false" data-no-lazy="1" class="fl-logo-img" itemscope itemtype="https://schema.org/ImageObject" src="https://www.dresdenenterprise.com/wp-content/uploads/2022/04/Enterprise-Flag-2022-CMYK.jpg" data-retina="" title="" alt="Dresden Enterprise" /><meta itemprop="name" content="Dresden Enterprise" /></a> </div> </div> <div class="col-md-4 col-sm-4"> <div class="fl-page-header-content"> <div id="webads_weather_widget-2" class="widget widget_webads_weather_widget pull-right">  <div id="webads-weather-38225" class="widget widget-webads-weather"> <a id="webads-weather-38225-link" href="https://www.dresdenenterprise.com"> <div class="awe-mini"> <div> <div class="col visual"> <span id="webads-weather-38225-temperature" class="temperature"></span> <i id="webads-weather-38225-image" class="weather-forecast-icon" style="background-size:contain"></i> </div> <div class="col info"> <span id="webads-weather-38225-location" class="location"></span> <span id="webads-weather-38225-conditions" class="forecast"></span> </div> </div> </div> </a> </div>  </div><div id="search-2" class="widget widget_search pull-right"><form aria-label="Search" method="get" role="search" action="https://www.dresdenenterprise.com/" title="Type and press Enter to search."> <input aria-label="Search" type="search" class="fl-search-input form-control" name="s" placeholder="Search" value="" onfocus="if (this.value === 'Search') { this.value = ''; }" onblur="if (this.value === '') this.value='Search';" /> </form> </div> </div> </div> </div> </div> </div> <div class="fl-page-nav-wrap"> <div class="fl-page-nav-container container"> <nav class="fl-page-nav navbar navbar-default" role="navigation" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement"> <button type="button" class="navbar-toggle" data-toggle="collapse" data-target=".fl-page-nav-collapse"> <span>Menu</span> </button> <div class="fl-page-nav-collapse collapse navbar-collapse"> <ul id="menu-main-menu" class="nav navbar-nav menu"><li id="menu-item-1076" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-1076 nav-item"><a href="https://www.dresdenenterprise.com/" class="nav-link">Home</a></li> <li id="menu-item-18943" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-18943 nav-item"><a href="#" class="nav-link">Local News</a> <ul class="sub-menu"> <li id="menu-item-767" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-767 nav-item"><a href="https://www.dresdenenterprise.com/category/news/" class="nav-link">News</a></li> <li id="menu-item-292" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-292 nav-item"><a href="https://www.dresdenenterprise.com/obituaries/" class="nav-link">Obituaries</a></li> <li id="menu-item-766" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-766 nav-item"><a href="https://www.dresdenenterprise.com/category/sports/" class="nav-link">Sports</a></li> <li id="menu-item-175627" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-175627 nav-item"><a href="https://www.dresdenenterprise.com/public-notices/" class="nav-link">Public Notices</a></li> <li id="menu-item-18946" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18946 nav-item"><a target="_blank" rel="noopener noreferrer" href="http://www.publicnoticeads.com/tn/search/searchnotices.asp" class="nav-link">State Public Notices</a></li> </ul> </li> <li id="menu-item-296" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-296 nav-item"><a target="_blank" rel="noopener noreferrer" href="http://1686.newstogo.us/editionviewer/default.aspx?Publication=ba990205-ee81-4972-941c-a544fa341ca1" class="nav-link">E-Edition</a> <ul class="sub-menu"> <li id="menu-item-18951" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18951 nav-item"><a target="_blank" rel="noopener noreferrer" href="http://1686.newstogo.us/editionviewer/default.aspx?Publication=3c1637aa-3958-45d5-b488-2a67385fbd2a&#038;view=archives" class="nav-link">Special Sections</a></li> <li id="menu-item-297" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-297 nav-item"><a target="_blank" rel="noopener noreferrer" href="http://1686.newstogo.us/editionviewer/default.aspx?Publication=ba990205-ee81-4972-941c-a544fa341ca1&#038;view=subscribe" class="nav-link">Subscribe</a></li> </ul> </li> <li id="menu-item-18944" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-18944 nav-item"><a href="#" class="nav-link">Connect</a> <ul class="sub-menu"> <li id="menu-item-293" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-293 nav-item"><a href="https://www.dresdenenterprise.com/photos/" class="nav-link">Photos</a></li> <li id="menu-item-290" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-290 nav-item"><a href="https://www.dresdenenterprise.com/event-calendar/" class="nav-link">Events</a></li> <li id="menu-item-289" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-289 nav-item"><a href="https://www.dresdenenterprise.com/crossword/" class="nav-link">Crossword</a></li> <li id="menu-item-18941" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-18941 nav-item"><a href="https://www.dresdenenterprise.com/community-links/" class="nav-link">Community Links</a></li> <li id="menu-item-18102" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-18102 nav-item"><a href="https://www.dresdenenterprise.com/datebooks/" class="nav-link">Datebooks</a></li> </ul> </li> <li id="menu-item-18945" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-18945 nav-item"><a href="#" class="nav-link">Submissions</a> <ul class="sub-menu"> <li id="menu-item-18018" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-18018 nav-item"><a href="https://www.dresdenenterprise.com/submit-a-classified/" class="nav-link">Submit a Classified</a></li> <li id="menu-item-18094" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-18094 nav-item"><a href="#" class="nav-link">News-Submit</a> <ul class="sub-menu"> <li id="menu-item-18095" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-18095 nav-item"><a href="https://www.dresdenenterprise.com/weddingsanniversaries/" class="nav-link">Weddings/Anniversaries</a></li> <li id="menu-item-18096" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-18096 nav-item"><a href="https://www.dresdenenterprise.com/obituaries-2/" class="nav-link">Obituaries</a></li> <li id="menu-item-18097" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-18097 nav-item"><a href="https://www.dresdenenterprise.com/general-news/" class="nav-link">General News</a></li> <li id="menu-item-18098" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-18098 nav-item"><a href="https://www.dresdenenterprise.com/birth-announcement/" class="nav-link">Birth Announcement</a></li> </ul> </li> </ul> </li> <li id="menu-item-4243" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-4243 nav-item"><a href="#" class="nav-link">Regional News</a> <ul class="sub-menu"> <li id="menu-item-4246" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4246 nav-item"><a href="https://www.dresdenenterprise.com/tennessee-news/" class="nav-link">Tennessee News</a></li> <li id="menu-item-4245" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4245 nav-item"><a href="https://www.dresdenenterprise.com/tennessee-titans-news/" class="nav-link">Tennessee Titans News</a></li> <li id="menu-item-4244" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4244 nav-item"><a href="https://www.dresdenenterprise.com/nashville-news/" class="nav-link">Nashville News</a></li> </ul> </li> <li id="menu-item-18939" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-18939 nav-item"><a href="https://www.dresdenenterprise.com/how-do-i/" class="nav-link">How do I…</a></li> <li id="menu-item-18940" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-18940 nav-item"><a href="https://www.dresdenenterprise.com/copyrightterms-of-service/" class="nav-link">Copyright/Terms of Service</a></li> </ul> </div> </nav> </div> </div> </header> <div class="fl-page-content" itemprop="mainContentOfPage"> <div class="webads-userbar-wrapper" style="display: none;"><span class="webads-userbar"><span class="webads-userbar-name"></span><span class="fl-sep"> | </span><a href="https://www.dresdenenterprise.com/wp-admin/admin-post.php?action=webads_logout&webads_logout_nonce=DS9URN7DtQcxre6U"><span>logout</span></a></span></div>  <div class="container"> <div class="row"> <div class="fl-content fl-content-left col-md-9"> <article class="fl-post post-252101 post type-post status-publish format-standard has-post-thumbnail hentry category-news" id="fl-post-252101" itemscope="itemscope" itemtype="http://schema.org/BlogPosting"> <header class="fl-post-header"> <h1 class="fl-post-title" itemprop="headline"> Not a Typical Tuesday </h1> <div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author" itemprop="author" itemscope="itemscope" itemtype="http://schema.org/Person">By <a href="https://www.dresdenenterprise.com/author/editor/" itemprop="url"><span itemprop="name">Editor</span></a></span><span class="fl-sep"> | </span><span class="fl-post-date" itemprop="datePublished" datetime="2022-09-16">September 16, 2022</span><span class="fl-sep"> | </span><span class="fl-comments-popup-link"><a href="https://www.dresdenenterprise.com/2022/09/16/not-a-typical-tuesday/#respond" tabindex="-1" aria-hidden="true">0 <i class="fa fa-comment"></i></a></span></div><meta itemprop="image" content="https://www.dresdenenterprise.com/wp-content/uploads/2022/09/Rons-Ravings-WEB-1.jpg"><meta itemprop="interactionCount" content="UserComments:0"> </header> <div class="fl-post-content clearfix" itemprop="text"> <p><img loading="lazy" class="wp-image-252060 alignright" src="https://www.dresdenenterprise.com/wp-content/uploads/2022/09/Rons-Ravings-WEB-1.jpg" alt="" width="201" height="339" srcset="https://www.dresdenenterprise.com/wp-content/uploads/2022/09/Rons-Ravings-WEB-1.jpg 533w, https://www.dresdenenterprise.com/wp-content/uploads/2022/09/Rons-Ravings-WEB-1-178x300.jpg 178w" sizes="(max-width: 201px) 100vw, 201px" /></p> <p><span style="font-weight: 400;">Like most Americans old enough to have a gray hair or two, I can clearly remember where I was and what I was doing on September 1, 2001.</span></p> <p><span style="font-weight: 400;">It was a Tuesday, which (for me at that time) meant it was deadline day at the Carroll County News-Leader in Huntingdon. </span></p> <p><span style="font-weight: 400;">As a 31-year-old staff reporter with just a couple of years of experience, deadline days typically involved gathering information via phone calls and faxed press releases, sorting through dozens of photographs, and trying to turn all that into readable news stories and features one after the other as fast as I could – along with anything else Shirley Nanney could think up for me to do.</span></p> <p><span style="font-weight: 400;">That day included all that, but it was far from a typical Tuesday.</span></p> <p><span style="font-weight: 400;">The first hint I had of how different that day would turn out to be was when one of my co-workers announced that her husband had just called and told her that a plane had crashed into the World Trade Center. </span></p> <p><span style="font-weight: 400;">For some reason, I just assumed it was a small aircraft of some kind, shrugged it off as probably no big deal, and kept on working.</span></p> <p><span style="font-weight: 400;">We didn’t have a TV or even a radio in the office and only one computer with dial-up internet access (which was usually tied up with something), so, ironically, we newshounds were probably behind most people when it came to knowing what was going on. </span></p> <p><span style="font-weight: 400;">But the news did get to us, piece by piece, phone call by phone call, as the events of that fateful morning unfolded, and concentrating on the work of getting a newspaper put together became harder and harder as the day progressed. Honestly, I’m not sure how we managed it.</span></p> <p><span style="font-weight: 400;">By noon, it was already feeling like we were living in another world.</span></p> <p><span style="font-weight: 400;">We heard that people were gathering for an impromptu community prayer session at the First Baptist Church downtown, and Shirley told me to walk over there and get some photos. </span></p> <p><span style="font-weight: 400;">On the way, I remember noticing how strangely quiet it was. Hardly any cars were out on the streets, and the clear blue sky overhead was undisturbed by any visible air traffic or the usual crisscrossing contrail lines.</span></p> <p><span style="font-weight: 400;">At the church, a few dozen people had joined hands in a prayer circle. I shot off several photos, and then I felt compelled to put down my camera and join them – so I did.</span></p> <p><span style="font-weight: 400;">It wasn’t until later that evening that I first saw the images that have since been forever seared, not just into my mind, but into our national consciousness as Americans. </span></p> <p><span style="font-weight: 400;">I had to cover a town board meeting in Bruceton, and they had a TV set up in the boardroom at city hall with the news going. Honestly, I really don’t remember anything about the business they conducted at that meeting.</span></p> <p><span style="font-weight: 400;">Looking back from 21 years later, those following days and weeks seem kind of hazy and surreal now. I remember feeling like I’d been kicked in the gut. I felt shocked. I felt angry. I felt scared about the future. I wanted someone to blame, and I wanted someone to pay for what had happened. And I think I was united with most of my fellow Americans in feeling that way.</span></p> <p><span style="font-weight: 400;">And for that brief season in American history, there was an unmistakable sense of unity in this country – something that, sadly, seems a million miles away from where we are now. For a time, we rediscovered public expressions of patriotism and faith and community spirit and an appreciation for those who put themselves at risk every day to protect and serve others, their country, and their communities.</span></p> <p><span style="font-weight: 400;">And a lot of things were born out of that time of unity – the launching of wars in Iraq and Afghanistan and a broader War on Terror, the passage of the Patriot Act, and the creation of the Department of Homeland Security, just to name a few.</span></p> <p><span style="font-weight: 400;">Now, I’m not going to try to analyze all that or make judgments as to whether those things turned out to be good or bad (or a mixed bag). That would be a long, complicated discussion.</span></p> <p><span style="font-weight: 400;">But I think we do need to ask ourselves if we have learned anything from 9/11 as a nation and a people. I would say that’s an honest and important question to ask.</span></p> <p><span style="font-weight: 400;">If we put aside all the political rhetoric and the designs and ambitions of powerful people, I believe there are some worthwhile lessons we can take away from that dark and tragic Tuesday. </span></p> <p><span style="font-weight: 400;">One is that evil is real, and there are a lot of people in this world who despise the freedoms and values we hold to as Americans – and that vigilance and strength and resolute purpose are necessary (and will always be necessary) to keep that evil at bay.</span></p> <p><span style="font-weight: 400;">Another is that, of all human activities, endeavors, and achievements, nothing is more deserving of honor and praise and remembrance than the laying down of one’s life while trying to save the lives of others. </span></p> <p><span style="font-weight: 400;">There was certainly a lot of that going around that day.</span></p> <p><span style="font-weight: 400;">And we would all do well to continue to honor and remember all those who lost their lives and gave their lives on Tuesday, September 11, 2001.  </span></p> <div class="addtoany_share_save_container addtoany_content addtoany_content_bottom"><div class="a2a_kit a2a_kit_size_32 addtoany_list" data-a2a-url="https://www.dresdenenterprise.com/2022/09/16/not-a-typical-tuesday/" data-a2a-title="Not a Typical Tuesday"><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=https%3A%2F%2Fwww.dresdenenterprise.com%2F2022%2F09%2F16%2Fnot-a-typical-tuesday%2F&amp;linkname=Not%20a%20Typical%20Tuesday" title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_twitter" href="https://www.addtoany.com/add_to/twitter?linkurl=https%3A%2F%2Fwww.dresdenenterprise.com%2F2022%2F09%2F16%2Fnot-a-typical-tuesday%2F&amp;linkname=Not%20a%20Typical%20Tuesday" title="Twitter" rel="nofollow noopener" target="_blank"></a><a class="a2a_dd addtoany_share_save addtoany_share" href="https://www.addtoany.com/share"></a></div></div> </div> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags">Posted in <a href="https://www.dresdenenterprise.com/category/news/" rel="category tag">News</a></div></div> <div class="fl-comments"> <div id="respond"> <h3 class="fl-comments-respond-title">Leave a Comment</h3> <form class="fl-comment-form" action="https://www.dresdenenterprise.com/wp-comments-post.php" method="post"> <label for="author">Name (required)</label> <input type="text" name="author" class="form-control" value="" tabindex="1" aria-required='true' /> <br/> <label for="email">Email (will not be published) (required)</label> <input type="text" name="email" class="form-control" value="" tabindex="2" aria-required='true' /> <br/> <label for="comment">Comment</label> <textarea name="comment" class="form-control" cols="60" rows="8" tabindex="4"></textarea> <br/> <div class="g-recaptcha" data-sitekey="6LdvRcMZAAAAAEXIplzSR6ZvSkSZTV1inA8BbwkV"></div> <br> <input name="submit" type="submit" class="btn btn-primary" tabindex="5" value="Submit Comment"/> <input type='hidden' name='comment_post_ID' value='252101' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /> <input type="hidden" id="ct_checkjs_6ea9ab1baa0efb9e19094440c317e21b" name="ct_checkjs" value="0" /> <div class="fl-comment-form-cancel"> <a rel="nofollow" id="cancel-comment-reply-link" href="/2022/09/16/not-a-typical-tuesday/#respond" style="display:none;">Click here to cancel reply.</a> </div> </form> </div> </div> <style>
                    .fl-post-featured-post {
                        border-bottom: 1px solid #e6e6e6;
                        margin-bottom: 10px;
                        padding-bottom: 0px;
                        margin-left: 20px;
                    }

                    .fl-post-featured-image-beside .fl-post-featured-image {
                        float: left;
                        width: 120px;
                        padding-right: 5px;
                    }

                    .fl-clear {
                        clear: both;
                    }

                    h5.fl-post-featured-title {
                        margin: 0 0 10px;
                        padding: 0;
                        font-weight: bold;
                    }

                    .fl-post-featured-image {
                        margin-bottom: 10px;
                    }

                    .fl-post-featured-image img {
                        height: auto !important;
                        width: 100% !important;
                    }

                    .fl-post-featured-header {
                        margin-bottom: 15px;
                    }

                </style> <div id="webads-related-posts"> <h3>Related Posts</h3> <div class="fl-post-featured-post fl-post-featured-image-beside fl-post-featured-has-image" itemscope="itemscope" itemtype="http://schema.org/BlogPosting"> <div class="fl-post-featured-image"> <a href="https://www.dresdenenterprise.com/2022/09/16/homecoming-queen-crowned-court-presented-at-dhs/" rel="bookmark" title="Homecoming Queen Crowned, Court Presented at DHS"> <img width="300" height="300" src="https://www.dresdenenterprise.com/wp-content/uploads/2022/09/DHS-HC-crowning-e1663343553233-300x300.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" loading="lazy" itemprop="image" /> </a> </div> <div class="fl-post-featured-header"> <h5 class="fl-post-featured-title" itemprop="headline"> <a href="https://www.dresdenenterprise.com/2022/09/16/homecoming-queen-crowned-court-presented-at-dhs/" rel="bookmark" title="Homecoming Queen Crowned, Court Presented at DHS">Homecoming Queen Crowned, Court Presented at DHS</a> </h5> <div class="fl-post-featured-meta"> <span class="fl-post-featured-date"> September 16, 2022 </span> <span class="fl-sep"> | </span> <span class="fl-post-featured-comments"> <a href="https://www.dresdenenterprise.com/2022/09/16/homecoming-queen-crowned-court-presented-at-dhs/#respond" tabindex="-1" aria-hidden="true">No Comments »</a></span> </div> </div> <div class="fl-clear"></div> </div> <div class="fl-post-featured-post fl-post-featured-image-beside fl-post-featured-has-image" itemscope="itemscope" itemtype="http://schema.org/BlogPosting"> <div class="fl-post-featured-image"> <a href="https://www.dresdenenterprise.com/2022/09/16/state-county-officials-encouraging-voter-registration/" rel="bookmark" title="State, county officials encouraging voter registration"> <img width="300" height="300" src="https://www.dresdenenterprise.com/wp-content/uploads/2022/09/TN-Your-Vote-Matters-WEB-300x300.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" loading="lazy" itemprop="image" /> </a> </div> <div class="fl-post-featured-header"> <h5 class="fl-post-featured-title" itemprop="headline"> <a href="https://www.dresdenenterprise.com/2022/09/16/state-county-officials-encouraging-voter-registration/" rel="bookmark" title="State, county officials encouraging voter registration">State, county officials encouraging voter registration</a> </h5> <div class="fl-post-featured-meta"> <span class="fl-post-featured-date"> September 16, 2022 </span> <span class="fl-sep"> | </span> <span class="fl-post-featured-comments"> <a href="https://www.dresdenenterprise.com/2022/09/16/state-county-officials-encouraging-voter-registration/#respond" tabindex="-1" aria-hidden="true">No Comments »</a></span> </div> </div> <div class="fl-clear"></div> </div> <div class="fl-post-featured-post fl-post-featured-image-beside fl-post-featured-has-image" itemscope="itemscope" itemtype="http://schema.org/BlogPosting"> <div class="fl-post-featured-header"> <h5 class="fl-post-featured-title" itemprop="headline"> <a href="https://www.dresdenenterprise.com/2022/09/16/utm-invites-high-school-students-to-fall-preview-days/" rel="bookmark" title="UTM Invites High School Students to Fall Preview Days">UTM Invites High School Students to Fall Preview Days</a> </h5> <div class="fl-post-featured-meta"> <span class="fl-post-featured-date"> September 16, 2022 </span> <span class="fl-sep"> | </span> <span class="fl-post-featured-comments"> <a href="https://www.dresdenenterprise.com/2022/09/16/utm-invites-high-school-students-to-fall-preview-days/#respond" tabindex="-1" aria-hidden="true">No Comments »</a></span> </div> </div> <div class="fl-clear"></div> </div> <div class="fl-post-featured-post fl-post-featured-image-beside fl-post-featured-has-image" itemscope="itemscope" itemtype="http://schema.org/BlogPosting"> <div class="fl-post-featured-header"> <h5 class="fl-post-featured-title" itemprop="headline"> <a href="https://www.dresdenenterprise.com/2022/09/16/dresden-seeking-funding-for-tornado-related-projects/" rel="bookmark" title="Dresden Seeking Funding for Tornado-Related Projects">Dresden Seeking Funding for Tornado-Related Projects</a> </h5> <div class="fl-post-featured-meta"> <span class="fl-post-featured-date"> September 16, 2022 </span> <span class="fl-sep"> | </span> <span class="fl-post-featured-comments"> <a href="https://www.dresdenenterprise.com/2022/09/16/dresden-seeking-funding-for-tornado-related-projects/#respond" tabindex="-1" aria-hidden="true">No Comments »</a></span> </div> </div> <div class="fl-clear"></div> </div> <div class="fl-post-featured-post fl-post-featured-image-beside fl-post-featured-has-image" itemscope="itemscope" itemtype="http://schema.org/BlogPosting"> <div class="fl-post-featured-header"> <h5 class="fl-post-featured-title" itemprop="headline"> <a href="https://www.dresdenenterprise.com/2022/09/16/dresden-elementary-martin-elementary-named-as-reward-schools/" rel="bookmark" title="Dresden Elementary, Martin Elementary Named As Reward Schools">Dresden Elementary, Martin Elementary Named As Reward Schools</a> </h5> <div class="fl-post-featured-meta"> <span class="fl-post-featured-date"> September 16, 2022 </span> <span class="fl-sep"> | </span> <span class="fl-post-featured-comments"> <a href="https://www.dresdenenterprise.com/2022/09/16/dresden-elementary-martin-elementary-named-as-reward-schools/#respond" tabindex="-1" aria-hidden="true">No Comments »</a></span> </div> </div> <div class="fl-clear"></div> </div> </div> </article> </div> <div class="fl-sidebar fl-sidebar-right fl-sidebar-display-always col-md-3" itemscope="itemscope" itemtype="https://schema.org/WPSideBar"> <aside id="adrotate_widgets-2" class="fl-widget widget_adrotate_widgets"><!-- Either there are no banners, they are disabled or none qualified for this location! --></aside><aside id="adrotate_widgets-3" class="fl-widget widget_adrotate_widgets"><div class="a-single a-10"><a onClick="ga('send', 'event', 'Adverts', 'click', 'Breaking News Signup', 1.00, {'nonInteraction': 1});" href="http://www.dresdenenterprise.com/breaking-news-signup/"><img onload="ga('send', 'event', 'Adverts', 'impression', 'Breaking News Signup', 2.00, {'nonInteraction': 1});" src="http://www.dresdenenterprise.com/wp-content/uploads/2016/04/breakingNewsHeader.png" /></a></div></aside><aside id="webads_facebook_widget-2" class="fl-widget widget_webads_facebook_widget"><h4 class="fl-widget-title">Like Us On Facebook</h4> <div id="fb-root"></div>  <div class="fb-page" data-href="https://www.facebook.com/DresdenEnterprise/" data-tabs="" data-width="" data-height="" data-small-header="false" data-adapt-container-width="true" data-hide-cover="false" data-show-facepile="true"><blockquote cite="https://www.facebook.com/facebook" class="fb-xfbml-parse-ignore"><a href="https://www.facebook.com/facebook">Facebook</a></blockquote></div> </aside><aside id="webads_displayads_widget-2" class="fl-widget widget_webads_displayads_widget"> <style>
                    #displayAds img {
                        width: 100%;
                        height: auto;
                    }

                                        #displayAdsWrapper {
                        height: 1500px;
                        overflow: hidden;
                    }
                    

                </style> <div id="displayAdsWrapper"> <div id="displayAds"> <ul id="displayAdsUL"> </ul> </div> </div>  </aside> </div> </div> </div> </div> </div> <footer class="fl-page-footer-wrap" itemscope="itemscope" itemtype="http://schema.org/WPFooter"> <div class="fl-page-footer-widgets"> <div class="fl-page-footer-widgets-container container"> <div class="fl-page-footer-widgets-row row"> <div class="col-sm-4 col-md-4 fl-page-footer-widget-col fl-page-footer-widget-col-1"><aside id="nav_menu-3" class="fl-widget widget_nav_menu"><h4 class="fl-widget-title">Dresden Enterprise</h4><div class="menu-footer-menu-1-container"><ul id="menu-footer-menu-1" class="menu"><li id="menu-item-228" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-228"><a href="http://www.dresdenenterprise.com/">Home</a></li> <li id="menu-item-230" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-230"><a target="_blank" rel="noopener noreferrer" href="http://1686.newstogo.us/editionviewer/default.aspx?Publication=ba990205-ee81-4972-941c-a544fa341ca1">E-Edition</a></li> <li id="menu-item-175628" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-175628"><a href="https://www.dresdenenterprise.com/public-notices/">Public Notices</a></li> <li id="menu-item-229" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-229"><a href="https://www.dresdenenterprise.com/contact-us/">Contact Us</a></li> <li id="menu-item-231" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-231"><a target="_blank" rel="noopener noreferrer" href="http://1686.newstogo.us/editionviewer/default.aspx?Publication=ba990205-ee81-4972-941c-a544fa341ca1&#038;view=subscribe">Subscribe</a></li> <li id="menu-item-232" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-232"><a target="_blank" rel="noopener noreferrer" href="http://1686.newstogo.us/editionviewer/default.aspx?Publication=ba990205-ee81-4972-941c-a544fa341ca1&#038;view=archives">Archives</a></li> <li id="menu-item-18936" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-18936"><a href="https://www.dresdenenterprise.com/copyrightterms-of-service/">Copyright/Terms of Service</a></li> <li id="menu-item-18935" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-18935"><a href="https://www.dresdenenterprise.com/how-do-i/">How do I…</a></li> <li id="menu-item-176803" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-176803"><a href="https://www.dresdenenterprise.com/datebooks/">Datebooks</a></li> </ul></div></aside></div><div class="col-sm-4 col-md-4 fl-page-footer-widget-col fl-page-footer-widget-col-2"><aside id="webads_syndicated_stories_menu_widget-2" class="fl-widget widget_webads_syndicated_stories_menu_widget"><h4 class="fl-widget-title">US &#038; World News</h4> <div><ul class="menu"> <li class="menu-item menu-item-type-taxonomy"><a href="https://www.dresdenenterprise.com/syndicated_category/united-states/">US</a></li> <li class="menu-item menu-item-type-taxonomy"><a href="https://www.dresdenenterprise.com/syndicated_category/sports/">Sports</a></li> <li class="menu-item menu-item-type-taxonomy"><a href="https://www.dresdenenterprise.com/syndicated_category/entertainment/">Entertainment</a></li> <li class="menu-item menu-item-type-taxonomy"><a href="https://www.dresdenenterprise.com/syndicated_category/technology/">Technology</a></li> <li class="menu-item menu-item-type-taxonomy"><a href="https://www.dresdenenterprise.com/syndicated_category/political/">Politics</a></li> <li class="menu-item menu-item-type-taxonomy"><a href="https://www.dresdenenterprise.com/syndicated_category/world/">World</a></li> <li class="menu-item menu-item-type-taxonomy"><a href="https://www.dresdenenterprise.com/syndicated_category/business/">Business</a></li> <li class="menu-item menu-item-type-taxonomy"><a href="https://www.dresdenenterprise.com/syndicated_category/health/">Health</a></li> </ul></div> </aside></div><div class="col-sm-4 col-md-4 fl-page-footer-widget-col fl-page-footer-widget-col-3"><aside id="nav_menu-5" class="fl-widget widget_nav_menu"><h4 class="fl-widget-title">Odds &#038; Ends</h4><div class="menu-footer-menu-3-container"><ul id="menu-footer-menu-3" class="menu"><li id="menu-item-216" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-216"><a href="https://www.dresdenenterprise.com/crossword/">Crossword Puzzle</a></li> <li id="menu-item-217" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-217"><a href="https://www.dresdenenterprise.com/event-calendar/">Event Calendar</a></li> <li id="menu-item-218" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-218"><a href="https://www.dresdenenterprise.com/photos/">Photo Galleries</a></li> <li id="menu-item-1473" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1473"><a href="https://www.dresdenenterprise.com/poll/">Online Poll</a></li> </ul></div></aside></div> </div> </div> </div> <div class="fl-page-footer"> <div class="fl-page-footer-container container"> <div class="fl-page-footer-row row"> <div class="col-md-12 text-center clearfix"><div class="fl-page-footer-text fl-page-footer-text-1">This website is powered by <a href="http://www.websitesfornewspapers.com" target="_blank"><i><strong>WebsitesForNewspapers.com</strong></i></a></div></div> </div> </div> </div> </footer>               
</body></html>
<!--
Cached page generated by Borlabs Cache - more information https://borlabs.io/
Time to create cache: 1.36225295 sec
Time to load cache: 0.05642104
Cache file created on: 2022-09-16T16:00:55+00:00
Current time: 2022-09-16T16:37:42+00:00
-->